1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

isarmatic 3 problems

Discussion in 'Western Plows Discussion' started by tleffelman, Nov 15, 2012.

  1. tleffelman

    tleffelman Junior Member
    from il
    Messages: 21

    hey guys new to the site but having some problems with my plow. changed the oil in it last night took it all apart and cleaded the inside out cleaned the filter. i pulled out the bottom flat head screw with the spring in it and checked that and put it back to together now it does not lift all i get is a low whining sound wondering if anybody has got any suggestions thanks
     
  2. Dogplow Dodge

    Dogplow Dodge 2000 Club Member
    from NJ
    Messages: 2,995

    go to western's website. They have a mechanics manual to explain on how to work on the motors.
     
  3. Chiputz

    Chiputz Senior Member
    Messages: 165

    Did you pull the pump out of the bottom of the housing? Might sound like a simple thing but did the o ring stay in place when you reinstalled it?
     
  4. tleffelman

    tleffelman Junior Member
    from il
    Messages: 21

    yeah i did pull put the pump to clean the filter. as far as i know the o ring stayed in place ill have to look at that again to see thanks
     
  5. tleffelman

    tleffelman Junior Member
    from il
    Messages: 21

    found out what the problem was it pays to put the pump back in the right way so thanks to the one guy that told me to look up the manual and the other person to make check the pump
     
  6. Chiputz

    Chiputz Senior Member
    Messages: 165

    Glad you got it working!