1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Is it the pump motor?

Discussion in 'Truck & Equipment Repair' started by LesleinLawn, Jan 1, 2009.

  1. LesleinLawn

    LesleinLawn Member
    from NE Ohio
    Messages: 98

    Myers unit, E47.

    Will not go up, left, or right. Down is good.

    Solenoid clicks. Have power into solenoid. Have power out of solenoid. Have power to pump motor.

    Is it the motor that is malfunctioning? If it is......

    Should I just buy new motor or try to replace brushes?


    Thank you, sure would like to finish my cleanups!!!
     
  2. cretebaby

    cretebaby PlowSite Veteran
    Messages: 4,162

    If it wont go up how do you know it will go down?:jester:
     
  3. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    if you motors bad get a new 1 rebuilds only last a year hell new 1 is cheap
     
  4. LesleinLawn

    LesleinLawn Member
    from NE Ohio
    Messages: 98

    it was up when I discovered the problem. Then I got it up (chain adjust) to get home and I can push down the ram. Thats how!!
     
  5. LesleinLawn

    LesleinLawn Member
    from NE Ohio
    Messages: 98

    anybody else please, am I on the right track?
     
  6. clark lawn

    clark lawn PlowSite.com Addict
    from NE ohio
    Messages: 1,233

    does the motor run and it does nothing or does the motor not do anything
     
  7. 04sd

    04sd Senior Member
    from pa
    Messages: 266

    Up, left, and right need the motor and pump to work. Down only needs the A coil and valve to work. If the motor doesn't run but it has power (and ground) it's likely a bad motor. If the motor is running then maybe a pump related issue.
     
  8. musicars

    musicars Junior Member
    Messages: 20

    If it sounds like the motor is running or trying to run then make sure the hydraulics are not just frozen up. My Western unit does the same thing and I have to heat up the unit to get it going again. But I can hear the motor, although it sounds real funny.
     
  9. LesleinLawn

    LesleinLawn Member
    from NE Ohio
    Messages: 98

    no motor is not running.

    Not a freezing issue.
     
  10. clark lawn

    clark lawn PlowSite.com Addict
    from NE ohio
    Messages: 1,233

    make sure you have a full 12 volts at the pump, use a multi meter not just a test light go from the hot lead on the pump to the ground on the pump. if you have power then i would say the pump is shot. like some one else already said if the pump is shot i would just get a new pump the ones ive had rebuilt only lasted about a year.
     
  11. LesleinLawn

    LesleinLawn Member
    from NE Ohio
    Messages: 98

    thank you everybody. Now that places are open today, I can get this thing fixed



    Think I might buy 2





    .