1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Intermittent Problem wtih Uni

Discussion in 'Western Plows Discussion' started by 02crew, Jan 3, 2008.

  1. 02crew

    02crew Junior Member
    Messages: 19

    Hi guys , I have a 7.5 foot Unimount Pro Plow on my truck, that I have had for 2 seasons now. It was used when I got it, but the price was right ( free ). Anyways, the problem that I an having is, every so often the plow will only turn left and right, but not go up, or not go down. When I get out of the cab, go out and wiggle the conltol harness, where the plow side & truck side plug together. it will start working again. I have cleaned both sides of the connectors and greased them up to prevent corrosion, but I think the problem is in the wires it self, and not the plug in.

    Is this a common problem for and older Uni Mount. And if so, what is the best way to fix it?

    Thanks
    Mike
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you look around on here a little you'll find that the grill plugs are very very common problem on the Uni's.

    Western has a repair kit that replaces the section of the harness at the grill connectors..you can buy either side individually or both sides as a kit.
     
  3. doh

    doh Senior Member
    Messages: 252

    I have had wires, almost completely broken on the solinoids, at the spade plug aswell. Shaking the wire does move them because there is no gromet on the solenoid cover that is screwed to the pump housing.