1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Intermitten Wiper Issues

Discussion in 'Ram Trucks' started by wildbl1500, Dec 29, 2008.

  1. wildbl1500

    wildbl1500 Senior Member
    Messages: 111

    Ever since I purchased my truck last year, the intermittent wipers have worked "funny". Sometimes they would do two swipes, sometimes only one.

    Now, it has gotten worse (probably because it's out of warranty). If I set them on intermittent they sometimes don't work at all or the intervals vary. High and low speeds work fine.

    I bought a new multifunction switch (stalk) and installed it last night. I still have the same issue...

    Any ideas?:confused:
  2. RamDude01

    RamDude01 Member
    Messages: 41

    Hi wildbl1500,
    I was having the exact same problem with my 98 2500 that I picked up last spring for another plow truck. It was doing that since I picked it up along with a few other 'electrical' issues. I did a lot of talking with mechanics at a few different shops and they all said that it was a bad ground somewhere. I went through and replaced ground wires, regrounded all the ones I could find with no help... then my alternator went out, so replaced it... was not charging the battery. Put another new one in again and the same thing. I even swapped out the computer (had a spare) with no help.

    Was planning on taking it to the dealer the next day and decided to take one last look. Just for sh*ts and giggles I decided to take the cable off from the fuse block to the positive battery terminal and give it a good filing and cleaning. It didn't look bad, but just thought it wouldn't hurt. Sure as hell, everything started working, alternator, wipers, all the other little problems... don't know if this will help your problem but you might want to take a look at all the connections and clean them all up. For me, the last one that I never thought was the problem turned out to be the problem. Good luck.
  3. wildbl1500

    wildbl1500 Senior Member
    Messages: 111

    Thanks I'll start there.
  4. Plow Dude

    Plow Dude Senior Member
    Messages: 280

    I have the same problem with my wipers. Sometimes they come on when I not even using them.
  5. wildbl1500

    wildbl1500 Senior Member
    Messages: 111

    at least I'm not alone...
  6. shott8283

    shott8283 Senior Member
    Messages: 258

    i know my truck has a faulty CTM (central timer modual) i fried my IOD fuze a while back screwing around with some wires, and burned up the CTM.. now my wipers only run on slow and fast.. intermitenant doesnt work at all..

    200 bux from the dealer to get a new one.. it can wait
  7. wildbl1500

    wildbl1500 Senior Member
    Messages: 111


    What year is your truck? Do you know where the CTM is located?
  8. shott8283

    shott8283 Senior Member
    Messages: 258

    mines an 01 and from what i understand its up behind the dash somewhere.. another reason why it hasnt been replaced yet