1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Integrated Brake Controller issue

Discussion in 'Chevy Trucks' started by CGM Inc., Apr 21, 2010.

  1. CGM Inc.

    CGM Inc. PlowSite Veteran
    from Ontario
    Messages: 3,589

    2007 GMC 2500 with brake controller as standard equipment.
    Display in das says service brake controller......
    Any idea what to do?
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    get down on your knees...:laughing:

    Take it to the dealer, see if they know.:D You could check to see if there is any off the dreaded galvanitic salt (battery corriosion) with in the factory bumper plug. That is a two piece plug, check between the plugs as well as opening the door. You have not added any plugs or modified the existing trailer wiring in any manner have you?
     
  3. CGM Inc.

    CGM Inc. PlowSite Veteran
    from Ontario
    Messages: 3,589

    no, all OEM I hope since I bought used. I check that out....
     
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    The factory controls are contrary and not as smooth or effective as the higher quality aftermarket units. Very particular as to ground and clean connections. They REALLY
    do not like additional plugs added to the system
     
  5. nate456789

    nate456789 Senior Member
    from Indiana
    Messages: 194

    Jst took mine to the Dealer for This

    I just took mine back to the dealer for this.
    Mine is integrated as well.
    The service guy said it was the fuse holder had a bad connection and it was the constant on and off that caused a relay to go out.
    They replace the fuse holder and relay and all is well now.
    Mine is a 2009 and still under warranty so I don't know what it would have cost.
     
  6. CGM Inc.

    CGM Inc. PlowSite Veteran
    from Ontario
    Messages: 3,589

    any idea which fuse? There is a bunch related to the trailer which i pulled and checked.
    Nothing really saying controller.
     
  7. nate456789

    nate456789 Senior Member
    from Indiana
    Messages: 194

    I usually work on my own stuff but this was a freebee so I don''t know for sure. I can try to look it up in the fact service manual.
    I would suspect a bad relay. But again I am not sure which one that would be without looking it up.
     
  8. CGM Inc.

    CGM Inc. PlowSite Veteran
    from Ontario
    Messages: 3,589

    great if you could do that!
     
  9. nate456789

    nate456789 Senior Member
    from Indiana
    Messages: 194

    I scanned some trouble shooting and diagrams from my factory manual for my 2009.
    Might be a little different for yours.
    PM me your email and I will send you the scanned pages.

    I'd attach it here but it is copyrighted stuff and I am sure they would delete it.
     
  10. vincent

    vincent Senior Member
    Messages: 171

    When you find out what is wrong, tell me. That just showed up on my truck also.