1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

install question - chevy

Discussion in 'Fisher Engineering Discussion' started by nogoodram, Nov 5, 2012.

  1. nogoodram

    nogoodram Member
    from RI
    Messages: 36

    hey guys, i'm sure its been discussed before but i can't find a good thread

    i'm installing a used 3 plug system on my 2000 chevy 2500. i'm using a kit removed from a 2001 chevy 1500. it is a yellow label 4 port isolation module. the short headlight harness has the pink wire to daytime running lights

    i did the install a few days ago and i hooked it up to my plow to test it. up/left/right works fine. the left headlight and turn signal worked but nothing on the right worked. and both the truck headlights stayed on the entire time (instead of turning off when the plow lights turned on)

    so yesterday i hooked it to a different plow (just to move the plow) and now the right headlight and turn signal work (but not the left). and this time the trucks headlights turned off when the plow was connected. but when i disconnected the plow, the trucks headlights didn't turn back on... and they wont turn on... when i turn the headlight switch to "on" the high beam indicator lights up on the dash, but neither the high or low beam will work..

    note - i have not hooked the pink DRL wire up to anything because none of the wiring diagrams clearly show where to splice it in. does anyone know which wire to hook it to? does it matter? i dont care if my plow has daytime running lights or not

    any thoughts on this??
     
    Last edited: Nov 5, 2012
  2. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Hooking up the drl will not change anything.
     
  3. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,245

    sounds like you don't have everything hooked up correctly but usually nothing works or the module has failed
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Is the 2000 an old body style? If so there's your problem. Need to reconfigure the headlamp harness's.