1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

insta act runs wont raise

Discussion in 'Fisher Engineering Discussion' started by johne19637456, Nov 11, 2009.

  1. johne19637456

    johne19637456 Junior Member
    Messages: 6

    hi i have a fisher mm with insta act. plow wont raise or go left, its all the way to the right so i don't know if that way works. I cleaned all connections, took pump off and took apart and cleaned lower end and screen, also took upper motor apart and cleaned it out. motor runs but nothing else. what can it be? thanks for your help.
     
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

  3. johne19637456

    johne19637456 Junior Member
    Messages: 6

    i put a test light on each of the 3 valves and and not getting anything when i go through the functions. i also tested magnetic pull with screwdriver and seems only middle valve reacts on each function, motor does run so power getting there. any ideas? thanks for your help.
     
  4. mcwlandscaping

    mcwlandscaping 2000 Club Member
    Messages: 2,557

    Wiggle the plug a little bit to try to get contact with the pins. You can also use a small screwdriver to close up the female plug end holes for a tighter fit and better contact. You can also take out each solenoid and cycle each remotely with 12v to make sure they work. I know you said you cleaned yÓur connectors but look closely at the control harness to check for corrosion.
     
  5. johne19637456

    johne19637456 Junior Member
    Messages: 6

    i found the problem, had a half broken wire on the plow side control harness going to the valves. i need to replce plow side harness. thanks for the help.