1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Insta Act motor removal?

Discussion in 'Fisher Engineering Discussion' started by 06Sierra, Sep 8, 2011.

  1. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    I need to put a new bushing in the manifold. Today I drained the fluid and took the whole unit off of the A frame. I got the resevoir off, and everything else on that end of the manifold. How do I get the motor off? I took the two long bolts out and it doesn't move at all. Is there something I am missing? What can I use to clean up some of the internals before I put it back together?
     
  2. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Take out the 2 bolts then get a hammer if that dont work a bigger hammer and be amazed of the amount of debris in there when it does come off.
     
  3. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Thanks. I got it off. One more question. When I took the pump out there was a small spring, I thought it was an o ring when it first fell out. Does that sit in the grove of the shaft seal, or does it just sit between the seal and pump?
     
  4. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Sounds like it's the garter spring off the old seal. Take a look at the old seal to see if it's missing. If that's the case, toss it... the new seal will have one.
     
  5. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Both seals look the same. No spring on the new one.
     
  6. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Id ck fishers site for a parts diagram.
     
  7. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    The diagram just shows an o ring. There was not an o ring when I took things apart. I have to get some new hoses any ways, so I'll check at brake service while I am there. Thanks for the help guys.