1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

I'm sure this has already been covered here...

Discussion in 'Western Plows Discussion' started by redskinsfan34, Jan 23, 2014.

  1. redskinsfan34

    redskinsfan34 Senior Member
    Messages: 876

    Hi guys. Pretty sure I have some Ice in the pump on my 8.5' pro plus straight plow. Could someone please direct me to a thread detailing a full fluid change including capacities? Also, I've been told to rinse it out with kerosene before refilling with new fluid. Any truth to that? And if so, how am I to be sure that all kerosene is out? Thanks for any replies.
     
  2. johnhenry1933

    johnhenry1933 Senior Member
    Messages: 256

    I would flush the rams and hoses with kerosene, then cleanse w/ ATF (to dissipate all the kerosene), and everything else (reservoir, cartridges, manifold) w/ brake cleaner and compressed air. The lower rams and hoses can be flushed in place by removing the hoses at the manifold, placing one hose in clean kerosene while the other hose is in a pail kept out of the expelled fluid (to prevent back-siphoning), and repeat this procedure (pushing and pulling the blade fully left then right) three or so times to flush the lower rams and hoses.

    Cleaning the reservoir, lift ram and manifold is best done dismantled, but you can get by w/o removing the manifold if there is virtually no contamination, and just remove the cartridges, crossovers and poppets for cleaning and inspection.
     
  3. redskinsfan34

    redskinsfan34 Senior Member
    Messages: 876

    Thanks for the reply.
     
  4. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    That sounds like a lot of work. Do yourself a favour and buy a bottle of sea foam trans tune. Drain off some fluid, add some trans tune(1/4 of the bottle) and use it for a storm then drain, clean filter, and refill with fresh fluid. No rinsing wondering if the kerosene ate the seals etc.

    trans-tune1.png
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,972

    Is this a unimount or ultramount?
     
  6. redskinsfan34

    redskinsfan34 Senior Member
    Messages: 876

    It's the old style so I think unmount.
     
  7. redskinsfan34

    redskinsfan34 Senior Member
    Messages: 876

    Thank you very much. I'll try that. I'm kinda Leary about tearing it all apart and the kerosene.
     
  8. johnhenry1933

    johnhenry1933 Senior Member
    Messages: 256

    1. Removing the hoses from the manifold is absolutely necessary to flush the lower rams. It cannot be done by simply adding Seafoam.
    2. That takes about 60 seconds.
    3. Flushing the rams as described takes 5-10 minutes.
    4. You need to remove the motor in order to the clean the filter and reservoir...takes 5 minutes.
    5. You only need to remove the manifold if [excessive] contamination is found.
     
  9. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    I agree that removing the hoses and changing the oil in the rams is important, that's part of the fluid change, my point was that you don't have to flush with kerosene, then cleanse that with ATF. seafoam is a wonderful cleanser that gets into the valves when their working cleans them and is compatible with everything already in the system. ....also takes care of moisture and prevents freezeup. Because it loosens it all up is why I suggested cleaning the filter.
     
  10. johnhenry1933

    johnhenry1933 Senior Member
    Messages: 256

    Oh. Ok. I just wanted the op to understand that a little dismantling is required to properly flush and clean. Thanks, John
     
  11. redskinsfan34

    redskinsfan34 Senior Member
    Messages: 876

    Thanks to both of you for your replies.
     
  12. redskinsfan34

    redskinsfan34 Senior Member
    Messages: 876

    Update. Ran the sea foam trans fix for 1 event. Drained and did a full fluid change. Plow runs like new. Thanks so much for the advice!!