1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Im in trouble! Need help please!

Discussion in 'Truck & Equipment Repair' started by Gmoser, Dec 8, 2011.

  1. Gmoser

    Gmoser Junior Member
    Messages: 15

    Okay here's my problem, I have a 1994 Chevy K2500 (light duty 6 bolt). I have not had any problems at all with the truck engine wise at all since I put a new engine in it (about 5,000 miles ago), which is the 350. I just put my plow on (steel western 7.6 w/ deflector) the other day and drove the truck around making sure everything was alright for season, the truck usually runs about 150-170ish on the temp gauge. As I am driving with the plow the truck warms it runs about 200-210 for a while but if I go up hill, drive to long or even am on the gas to much it jumps to 240-250, (we haven't had our first storm yet so I am very worried about what will happen after a few hours of plowing will do to it). I haven't let it go past that, as I would imagine it will keep climbing till I have a bigger problem.

    This fall I installed a new temp gauge (regular stant), a aftermarket trans cooler, a new water pump, all new hoses and clamps, just had new antifreeze put in it and the radiator itself was replaced within the last year.

    I am wondering if maybe its my serp belt slipping?(even tho I am highly doubting there is slipping going on) maybe my fan clutch? or I have heard about water pumps being the wrong model for these trucks and spinning backwards or something? (but so far has not showed any signs of that being possible) or the last thing I can think of, my air conditioner condenser is beat up pretty bad, could that be causing poor air flow? I have drove with the blade in every way possible low, high, straight, left, right. It seems to be best when its straight and as low as possible and I mean low, but none the less it will still go towards overheat.

    I tried to give the best description of my problem I could, I'm really hoping someone can maybe help me out or have dealt with and figured this situation out in the past. Any info would help and be greatly appreciated!!

    Thank you for the time!!
  2. Look in to the heavy duty fan clutch.
  3. Gmoser

    Gmoser Junior Member
    Messages: 15

    It seems like all the post I have been reading from the past point to that too. I will be looking into that tomarrow, thank you for your response.
  4. 87chevy

    87chevy Senior Member
    Messages: 557

    Keep your plow as low as you can, my 87 will do the same thing. Not getting enough air through the rad

    Never mind, missed that part. I guess making sure the fluids are topped off is good, I was a gallon low in the 87 when it was doing it.... Not sure where that went but idk if I want to..

    I've heard things about those water pumps too. Blow or wash your radiator out. See how much crap is in there
    Last edited: Dec 9, 2011
  5. pooleo8

    pooleo8 Senior Member
    Messages: 271

    your just not getting enough air thru the front. I had this problem with my ranger. I removed the factory fan/clutch and installed a flex fan. I dont have anymore cooling problems.

    here is a video of the fan, fwiw.

  6. bigboss1

    bigboss1 Member
    from pa
    Messages: 35

    i have a lower temp thermostat in my 94 i think it opens around 165ish i never have overheating issues even with the plow on and the best part is its a cheap easy fix
  7. deere615

    deere615 2000 Club Member
    Messages: 2,919

    yep heavy duty fan clutch usually about 60 bucks or so and not too hard to change. most chevys that plow need that upgrade
  8. PDQ Pete

    PDQ Pete Senior Member
    Messages: 139

    Some people say a deflector on the plow helps the airflow.
  9. Gmoser

    Gmoser Junior Member
    Messages: 15

    I think I will be buying a hd clutch for the fan today, I was told at the auto parts store up here that I should just pull the spring on the fan? Before spending the time and money on the clutch, he said that would almost help as much as the clutch itself. I pulled the air consenser out and I do have a deflecter on my plow. I also am putting on a piece of metal that will be mounted on the plow setup (on the straight piece above of the top hydraulic) to make some air shoot down right into my radiator.

    But all in all I am thinking the fan clutch will be my best way to go, I will try everything else out first because it's all ready to try, if I get a high temp my next step would be the clutch. Does anybody know something about removing the passenger headlight so the cold air intake is open? A local guy suggested it, to put a small blocker to hide wires and such, but leaving half open to allow massive cold air. Would this be worse then good? Or has somebody had good luck with that before?

    I will keep my post updated an let everyknow what worked for me! Thanks again for all the help, all the info on this I can get is great and every post helps!!