1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

I have a misfire on my 7.4

Discussion in 'Chevy Trucks' started by bsmitty, Aug 27, 2011.

  1. bsmitty

    bsmitty Member
    from Chicago
    Messages: 47

    Looking for a little help with a mis I have on my GMC 3500HD dump. It is the 7.4L gas motor, and when it would rain or sit for a while it would mis for a little while when you first start it until it warmed up and then the mis would go away. I haven't driven the truck in awhile and I took it on a job and it is missing again but it won't go away this time. Any ideas or thoughts would be really helpful.


  2. 496 BB

    496 BB Senior Member
    Messages: 789

    Could be a million things. Ive had bad plug wires make a miss when water hits em. Ive had cats get plugged. Could be fuel filter. Could be plug gaps. List goes on and on.
  3. Western1

    Western1 Senior Member
    from MI.
    Messages: 668

    Try a misting bottle of water when its dry and running. Most likely cap and wires would cure it,probably overdue for that anyway.
  4. 70monte

    70monte Senior Member
    Messages: 468

    If it is missing when its wet or rainy, its a good indication that your cap may have a crack in it or that your plug wires have broken down. I would do a tune up on it if it has been a while.

    I have a 7.4L in my 98 K3500 and mine will idle rough when sitting at a stop in gear or out but will run smooth going down the road. I replaced pretty much all of the ignition stuff on it when I first bought it.