1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

hoods raised plow dont work(safety device)???

Discussion in 'Sno-Way Discussion' started by mtloveland, Jan 29, 2007.

  1. mtloveland

    mtloveland Junior Member
    Messages: 5

    just curious when installing plow did wiring harness ,subframe ,then put power unit on truck with out blade on it and tried to test up,down,left,right and it jolted once and then did nothing but make sort of a light static clicking noise in the wireless reciever but had power every where else after 20 mins of messing with it i gave up close the hood and backed out of garage got out of truck and bump wireless remote and it moved tried it and everything worked scratched head popped hood didnt work again whats up i have no under hood light how is it doing it vehicle is a 2003 chevy 1500 with 7'6" poly wireless mt series
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    You wired something wrong, go back and double check your power and ground configurations
  3. vwovw

    vwovw Senior Member
    Messages: 190

    sound like you might be wired wrong. alarm? ground? engine bay light? must be shutting it off.
  4. mtloveland

    mtloveland Junior Member
    Messages: 5

    checked every connection power lead from battery to circuit breaker from there to plow wiring harness is all plugged in right only one wire to ground to chassis and it is good checked again today and power plow up pop hood still works lift hood slowlyfrom latched position with up button pushed as soon as hood1 1/2" gets where you would think the bay light would come on and just stops working and get that light clicking sound from receiver isnt really a problem would stop from crushing me if i forgot to shut off remote but baffling ill call sno way tech see if they have any answers thanks
  5. mtloveland

    mtloveland Junior Member
    Messages: 5

    thanks for the help or attempt found problem. ground issue