1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Hitachi EX75 UR excavator stalling under load.

Discussion in 'Heavy Equipment' started by bgingras, Aug 2, 2010.

  1. bgingras

    bgingras Senior Member
    Messages: 282

    I was asked to run a Hitachi excavator for someone who clearly had no idea of how to operate or maintain what they own. It's a EX75 UR with blade, intermediate joint on the boom and steel tracks. While running, each time I put the hydros under load the engine would bog down or stall all together. I had the engine at full speed, but couldn't so much as use the tracks to turn becuase of the strain and stall. I asked about maintenance. In 2 years he's never changed a filter of fluid in it. The engine does seem to idle fine while not under load, but stalls quickly when trying to do something. There is also an intermittent alarm sounding but it will stop when you move of use any hydro element. My first thought was a clogged filter. I have him buying all filters and new fluids to do a complete change, but does it sound like there may be another issue going on here? I'm stumped, as I usually don't deal with the PM stuff on these machine, I just get stuck digging people out of holes :)
     
  2. DGODGR

    DGODGR Senior Member
    from s/w co
    Messages: 639

    You are approaching the problem reasonably. Start with the simple cheap fixes. A clogged fuel, hydraulic, or air filter (or all three) could cause this. If this does not correct the problem you may have to look at main relief pressures, and/or circuit resolvers (if it has load sensing hydraulics), and/or fuel pressure to fix it. If the filters don't do it, I would suggest posting on Heavy Equipment Forum for further assistance.