1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Hiniker Question

Discussion in 'Hiniker' started by sledneck24x, Jan 23, 2011.

  1. sledneck24x

    sledneck24x Senior Member
    Messages: 107

    Hey Guys I am new to the Snow plow World. I Just bought a 2001 F250 7.3L Diesel with a Hiniker V plow. It is a a bit older. Heres my Questions when I hook it up and plug everything in. and push up on the remote it either doesnt go up right away or it goes up really slow and drops the second i let go of the up switch. Then after 5 minutes or so it stays up by it self then when i press left or right it drops really slow again then after another few minutes it works just fine. Is this normal?
    Last edited: Jan 23, 2011
  2. dforbes

    dforbes Senior Member
    Messages: 247

    No it is not normal. I never heard of this problem before. My thought would be a weak selinoid. I am sure you will get more answers before long. Good luck, I have a hiniker V and love it.

    NICHOLS LANDSCA PlowSite Veteran
    Messages: 4,286

    I'd start by checking the pins, male and female on the plugs. Then check the UP valve on the pump, see if there is a piece of junk in it or replace it. You could figure out if part of it is a mechanical problem or electrical. Get the plow to go up, then unplug the wire connections from the plow to the truck. If the plow still goes down you know it's mechanical (valve). If it doesn't you know it's electrical (bad connection/pins or controller)