1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Hiniker plow problem, need help

Discussion in 'Hiniker' started by 59medic, Dec 20, 2009.

  1. 59medic

    59medic Member
    from Ohio
    Messages: 33

    Just hooked my plow up today, it will angle to the left, but not to the right. The motor runs when you try to angle it, but hydraulic does not move. Took the hydraulic line loose when you try to angle, fluid just barely runs out the line. Any ideas or thoughts are greatly appreciated. Thanks
     
  2. Ultimate Trucks

    Ultimate Trucks Junior Member
    from Indiana
    Messages: 10

    The solenoid on the top of the block is bad.
     
  3. 59medic

    59medic Member
    from Ohio
    Messages: 33

    Is there anyway to test it?
     
  4. MileHigh

    MileHigh PlowSite.com Addict
    Messages: 1,827

    Mine does similar when the hookups get ****** up or a bit corroded.

    dieelectric grease and a little shaking does the trick for me.
     
  5. 59medic

    59medic Member
    from Ohio
    Messages: 33

    Thanks BladeScape I will have to check the connections, and make sure that I am getting power.
     
  6. NICHOLS LANDSCA

    NICHOLS LANDSCA PlowSite Veteran
    Messages: 4,302

    Check the pins, one of my guys jamed the plug together once and pushed 2 of the female pins in/back
     
  7. 59medic

    59medic Member
    from Ohio
    Messages: 33

    Thanks Nichols I will check that when I get home from work.
     
  8. 59medic

    59medic Member
    from Ohio
    Messages: 33

    Plow Fixed Thanks

    Thanks to everyone that responded. After looking at the wiring I have figured it out. I bought the plow used and the original owner put new ends on the truck and plow, had the tan solenoid wire hooked into the brown wire for the lights. No wonder they wanted to get rid of it!!