1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Hiniker low beams not functioning

Discussion in 'Truck & Equipment Repair' started by firecaptain2009, Jan 8, 2015.

  1. firecaptain2009

    firecaptain2009 Junior Member
    Messages: 2


    I am using a straight blade hiniker plow - home use here. The lights on the plow have not been working all season, and I've been too lazy to work on them...

    I discovered quite by accident tonight, that the lights on the plow DO work, when the truck lights are set on the high beam. When I flip the truck to low beam, the headlights go out - the running lights/turn signals work all the time.

    When I switch over to the truck lights (even with the plow still attached), both high and low beams work as normally.

    Any input on what to look for would be greatly appreciated! I'm working with a 1992 Ford F150 here.

    Messages: 31

    relays on wiring harness has gone bad u can find these at any part store simple 12 volt relay
  3. firecaptain2009

    firecaptain2009 Junior Member
    Messages: 2

    Thanks for the quick reply... Sounds like an easy repair. I'm afraid I have to show my ignorance here, but could you describe what I should look for, and where I might likely find it...?