1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

High beam issues

Discussion in 'Boss Plows Discussion' started by T-CON, Mar 17, 2007.

  1. T-CON

    T-CON Junior Member
    Messages: 7

    We just installed a 8' 2" V on a 2007 chevy 2500 classic tonight. It is a used plow but with new headlight adapters.

    The issue is the high beams on the plow barely come on, very dull and come on slowly. All lights on the truck work fine just an issue on the plow.


  2. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    no lights

    is this a smart hitch 2 plow ?better check you grounds for your head lights you might have to run new grounds out the headlight housings,was your light adapter part #msc04601?you could have a relay problem.:confused:
  3. T-CON

    T-CON Junior Member
    Messages: 7

    It is a smart hitch 2 and I double checked that it is the right head light adapters.

    My thoughts are also that it is acting like a ground issue. The low beams work perfectly, it is isolated to the high beams.

    I have not really had a chance to diagnose it because 3 hours after finishing the install we were called out to plow for 11 hours straight. Hopefully tomorrow I will have a chance to work on it.
  4. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239


    good luck!:salute: