1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HID Problems

Discussion in 'Boss Plows Discussion' started by DaySpring Services, Jan 30, 2009.

  1. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    So I decided to get aboard the Hid craze. I ordered a set of Digital HID's off ebay. They're 55watt and I only did the low beams. I've been having problems with them flashing or going off. My plow plug was pretty iced up, I cleaned that up and it helped a bit. However they're still flashing on and off every now and then. It slowly gets worse once they start flashing. Can I have a bad relay or maybe the wires are shoved too tight against the ballast. One more thing to add, I did put dielectric grease on all connections, any possibility it can be that (Even though I doubt it.)
     
  2. ProSeasons

    ProSeasons Senior Member
    Messages: 624

    Is the computer confused by the digital ballast and thinks that there is not enough load on the circuit, causing it to try to reset itself, hence the flashing on and off? I know some guys on here had that problem and remedied it by installing a resistor in the circuit to place additional load on the computer. Do a 'search' and read up a little. Maybe you'll find something.....I don't know.
     
  3. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    I ordered the relay harness, gonna give that a try. I'll post results later this week.
     
  4. tbirdhau

    tbirdhau Junior Member
    Messages: 25

    Did you get that relay harness yet? I'm having trouble with mine also. They flash on and off and I can't get both side to work. I have a 06 Ford Super duty. What is your truck. How will you install the wiring harness so when you remove the plow it stay's with the truck
     
  5. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    I probably wont get it till Thursday or Friday. The problem I am having is sometimes they'll work for a couple mins, up to about 10. Then they start to flash on and off and one or 2 will go out for awhile. I turn my high beams (standard bulbs) on for a bit, then try the hid's again which work. I'm not sure what the harness looks like yet, but i'll probably just use some sort of crimp on connectors to make a quick disconnect. It will be a pain to have extra wire to plug in but it will be worth it. They are awesome when they work!
     
  6. tbirdhau

    tbirdhau Junior Member
    Messages: 25

    where did you order the wiring harness from. Let me know if it solves the problem
     
  7. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    I got mine from retro-solutions on ebay, that's whoI got my HID's from. If you are looking for the relay for the low beams on the boss plow it's Item number: 350148451463