1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Hey Guys need some help here

Discussion in 'Residential Snow Removal' started by taztech2010, Dec 11, 2009.

  1. taztech2010

    taztech2010 Junior Member
    Messages: 2

    Hey guys, finally found a site about plows, i need it for sure..

    Never had a plow , finally...now heres the deal go a western hydraulic setup on older full size blazer. just got it up and going.. had it working fine, except for the plow would angle right and get stuck, had to manually move it..was lifting and stuff just fine the other day...

    got into today, would n't lift at all ..nothing, could hear motor running, but nothing..
    its not stuck on ground, I was able to move it, so thats not problem..

    any body have any ideas...kills my battery when i even rev truck to lift it..still nothing?

    appreciate the help in advance, need to get it going..cold as heck here in Mi..drives getting stuffed with white crap

    By the way its older, just the plow blade comes off truck,, pump assembly and lights stay on truck..

    Last edited: Dec 11, 2009
  2. magik235

    magik235 Senior Member
    Messages: 113

    Is the pump full of fluid?
    Are the cables adjusted correctly?
  3. taztech2010

    taztech2010 Junior Member
    Messages: 2

    don't know really anything about plowing yet, first one ever...what all are the basics.how do you check fluid and cables?

    thanks for replying
  4. magik235

    magik235 Senior Member
    Messages: 113