1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help!!!

Discussion in 'Boss Plows Discussion' started by FF/P215, Dec 26, 2012.

  1. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    I took the plow off yesterday, brand new VXT, no problems... trying to hook it up now, not getting any power when I flip from truck to plow, can't go thru the motions with the controller! No power at all! On a duramax, anybody?! Posting this to Chevy forum too...
     
  2. Cover Guy

    Cover Guy Senior Member
    Messages: 224

    Did you put the controller in the float position if not do that and that will let you run the switch on the plow
     
  3. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    No power to the controller either
     
  4. Cover Guy

    Cover Guy Senior Member
    Messages: 224

    I assume the controller is turned on if so there is a keyed wire close to the controller plug make sure it has power when the key is on it should have a fuse also you can check
     
  5. qualitylawn

    qualitylawn Senior Member
    Messages: 122

    i had exact same problem yesterday check your fuses ,mine turned out to be one of my relays may have gotten bumped one was not pushed in all the way glad it was that simple!
     
  6. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    Been thru them, or I think I've been thru all of them, this was a last resort, I'm going to do it again.. thanks guys I'm currently freaking out
     
  7. Spool it up

    Spool it up Senior Member
    Messages: 912

  8. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    Already been on there, doesn't even show up as an option..
     
  9. Spool it up

    Spool it up Senior Member
    Messages: 912

    sorry dude . wrong linky . gotta be an inline fuse/fuse blown .start combing the wiring to and fro
     
  10. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    Thanks man, I'm gonna try that
     
  11. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    Just tried all the fuses, not a thing, I don't know, guess I'm going to have to go bust my knuckles and hook the Fisher up to the other truck for now...FML
     
  12. Spool it up

    Spool it up Senior Member
    Messages: 912

    12-14'' in the hood .....holy mackeral , gee wilikers and wtf . get er dun , son
     
  13. Spool it up

    Spool it up Senior Member
    Messages: 912

    thats a disgrace them damn installers . braaaan new BOSS DADDY . id hunt his ace down . most of them are open during a storm .

    good luck and stand by for the BnB post
     
  14. Cover Guy

    Cover Guy Senior Member
    Messages: 224

    Does the keyed switch wire have juice
     
  15. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    I'm hoping BnB has some insight, I called my installer and no answer... I might call the other couple in the area.. Need something, it's gonna be sad that the Fisher is going on...
     
  16. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    Nothing.. and I can't get ahold of my dealer...
     
  17. Spool it up

    Spool it up Senior Member
    Messages: 912

    guess he took off in the fisher
     
    Last edited: Dec 26, 2012
  18. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    thanks spool it up I sent him a message, unfortunately the fisher is buried already... I'm in the process of getting rid of it for a Boss straight blade... guess I'm sitting here until I can fix this thing, or my dealer opens
     
  19. Spool it up

    Spool it up Senior Member
    Messages: 912

    dude , with 12-14 falling , i'd keep tracing . did you check the fuse port . possibilities ....positive fell outta the fuse box .
    you plugged your controller in backwards
    battery connection loose /off .
    hopefully its not a bad controller .

    are you using a test light tool ? i dug up all the schematics i could .

    use the search here , i'll keep digging /searching controller links to ya :nod:
     
  20. FF/P215

    FF/P215 Senior Member
    from 01085
    Messages: 177

    Thanks, I can't look any deeper, we are probably pulling the same things up. I found one from a couple years ago that seemed to a similar issue but it hasn't changed the outcome, but I'm just so p*ssed off right now.. I've been thru everything I possibly think I could, I'm cold, I'm soaked, steam blowing out both ears and nostrils, I've followed the lines from the battery to the solenoid to the other side of the firewall and back and from the other side of the fire wall to the controller... Controller never came off, took the plow off yesterday morning without any problems, there has to be a large scale power issue or a small one on the inside of the firewall that I'm missing.. I'm guessing it goes right back to the switch, or something around it...