1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

help

Discussion in 'Western Plows Discussion' started by hondarider203, Dec 4, 2010.

  1. hondarider203

    hondarider203 Member
    Messages: 38

    western unimount poly pro is there a way to power bleed the hydro system on these i have let it sit for about two mounths and gravity bleed but snow is coming and it seems like i still have air in it. up and down seem ok left and right it wines real bad and is extremly slow. would this be air? if so can eny one tell me how to get it out??
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    make sure it is full of oil. as much as you can get in it. then just run the plow through all functions. the air will come right out.
     
  3. hondarider203

    hondarider203 Member
    Messages: 38

    ive done that and left to right it is solid as a rock cant move it at all by hand but its still whining like crazy and still moving real slow. i know up and down has an ajustment screw for speed is there something like this for left and right maybe??
     
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    no speed adjustment for angle. a whining pump means plugged filter or low oil usually.
     
  5. hondarider203

    hondarider203 Member
    Messages: 38

    ok i will check the filter since the oil is full will i loose fluid or risk air in the systom since i just got it all out
     
  6. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    pull the motor and pump off. clean the filter and reinstall. should lose very little oil. air in a unimount is a non issue.
     
  7. 33yearsinsnow

    33yearsinsnow Senior Member
    from ohio
    Messages: 111

    You say up/down is OK is that with the plow hooked up or just the hydraulic unit running by itself?
     
  8. hondarider203

    hondarider203 Member
    Messages: 38

    its all one unit.. up and down is real slow to untile it gets warm then it starts working right again show it do this i have never had that before is it maybe because it has all new oil/maybe a little thiker then the old stuff??