1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help with Fisher MM1 plow !!!!!

Discussion in 'Fisher Engineering Discussion' started by livetoplow, Jan 24, 2011.

  1. livetoplow

    livetoplow Member
    Messages: 49

    Hi everyone. I just went to get in my truck to go up to the store. Went to lift my plow and nothing. It moved up a few inches and then stopped. I can still hear the motor working no problem but the plow does not move in any direction. It was just working fine the other day in the storm. Had it sitting there for a few days in the cold without starting it.

    Can someone please help me ? Does it sound like something major ? Maybe something is frozen ?

    Anyone that may be familiar with this please help me as i am in a panic since we may have snow coming on Wen and Thur

    Thanks !
     
  2. dmen

    dmen Junior Member
    from maine
    Messages: 28

    i had the same problem last week, ended up being two wires cam detatched from the solenoid. With the help of this site i was able to find the problem and fix it.Look for the thread i started titled, Plow won't Move.
     
  3. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Your fluid probably has water in it and froze. Just had the same issue with mine today with the extreme cold. Drain system, remove motor and filter, clean out as much of the old fluid as possible and wipe out the reservoir. Clean or replace the filter. Make sure you drain the rams also. Refill and your good to go.
     
  4. livetoplow

    livetoplow Member
    Messages: 49

    I know this sounds horrible but i do not know how to do those procedures you just mentioned. I keep getting the run around from Wright Trailer, which is near me, to do what you just said. It has not been done in 3 seasons. I keep on making app. with these guys as they are the only ones i know that will work on them around me, they keep blowing me off. " Sorry we have a lot of new plows for customers to put on. Can you we pencil you in for a week or 2" :realmad: I just got fed up with it and now am left with no one with the knowledge. I am willing to pay for someone to service my set up. I told Wright Trailer this same thing. I would think i should be just as important of a customer as someone with a new plow but thats just me. I run a landscaping business as well as do the snow removal in the winter and i would never turn away someone like that.

    So the lack of Maint. is my fault but then again not. Would you or anyone else with the knowledge be willing to do the flush and filter etc and shoot me a price if interested. I hate not having things running 100%.

    Would love to do this myself but do not want to mess anything up in the process. Do not know if i can get lost quick doing this. Just i am in a panic as snow will be here Wen and i can not throw money away if the plow does not want to work.
     
  5. livetoplow

    livetoplow Member
    Messages: 49

    I just saw your Thread. Where is the solenoid you talk about ? I do not have the ISO box setup on my fisher. It is the relay system. Have to get this up and running for Wen storm
     
  6. dmen

    dmen Junior Member
    from maine
    Messages: 28

    The solenoids are under a cover near your reservoir. there will be wires going into each one. Look at the diagram that repoman posted, i believe he posted a diagram of your setup. Hopefully he wi chime in, wirhout him i would still be without a plow.
     
  7. livetoplow

    livetoplow Member
    Messages: 49

    Ya i mean everything worked no issues the other day and it has not moved since. Just been there parked ready to work. It raised up a few inches and then that was it. Still hear the motor but no movement now.
     
  8. quigleysiding

    quigleysiding PlowSite.com Addict
    Messages: 1,097

    Where are you in R.I
     
  9. manheimmike

    manheimmike Junior Member
    from dighton
    Messages: 1

    I'M right in your area and purchase all my parts from wright but repair all my own equipment . I have everything from avalanche to western and fisher and boss if you still need help i'll set some time to look at the unit.
     
  10. livetoplow

    livetoplow Member
    Messages: 49

    Ya i live in Middletown. Right next to Newport. I am very interested if you have the knowledge of Fisher plows and the relay setup like mine. I have wanted to switch to the ISO setup since i hear it is better but i hear it is $ 850 in parts alone.

    When would you be available to look over my system ? I would love to try to get it looked at before the storm on Wen night if all possible.

    It may raise tomorrow when the temps get up but that still does not take away from the fact that i need to have my setup serviced for sure.

    Are you familiar with wiring as well ? I have not had lights from the Fisher harness in a few years. I had to run a hot lead from my headlights and tap into the Headlight wires on the plow side. Would like it wired the right way. I can do that whenever you are available i am just trying to get back on the road asap. Then i would have you do the wire job if you are familiar


    Thanks ill wait to hear back from ya ! Thumbs Up
     
  11. livetoplow

    livetoplow Member
    Messages: 49

    Middletown RI. Right next to the Newport line
     
  12. quigleysiding

    quigleysiding PlowSite.com Addict
    Messages: 1,097

    If you get in a jam you can bring it over and I can show you how to change the fluid and clean the filter. Did you check to see if the fluid was low?. I am just over the bridges. I get out of work around two tomorrow.I'm going to be in the garage anyway getting ready for the storm.
     
  13. fordpusher

    fordpusher Member
    from mass
    Messages: 31

    i have used metropoltian truck in stoughton ma. they have like 10 bays and fix it while you wait
     
  14. snowman123

    snowman123 Senior Member
    Messages: 205

    When you say you here the motor turning are you sure you mean the motor and not the solenoid that just clicks. I had a similar problem on my minute mount 1 but it was just the plugs by the bumper that got disconnected. Check to see if their is snow in the plug that would also make it not work.
     
  15. livetoplow

    livetoplow Member
    Messages: 49

    Hey Everyone


    Just a update. I fixed the issue. After help from members of this forum, I looked on how to flush the hydro fluid in my MM1. Opened it up and WOW. The hydro fluid looked like milk with slush in it. Cleaned it out many times and cleaned the filter. Put some Fisher Blue in it. Its like a brand new plow. Never moved this fast in its life. Thanks again for members helping me out !