1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help with 1.5 yard salt dogg polycaster

Discussion in 'Commercial Snow Removal' started by phil7712, Dec 30, 2012.

  1. phil7712

    phil7712 Junior Member
    from boston
    Messages: 5

    So this year we purchased a 1.5 yard salt dogg polycater spreader. This unit is brand new and is auger driven with a vibrator. First time out i felt spreader was not performing well for i had to use the vibrator constantly to have a decent spread. 50-50 salt/sand mix. About half way throgh the load the auger setting started flashing and cliking and adventually the spinner icon read the letter f. I assumed this was a clog and brought truck back to heated garage for the night. The next day i moved some sand around from the top and it started to work properly. I figured proably just wet sand no big deal. Took the spreader out today with a load of 100% dry straight salt and same thing happen less with half a yard still in spreader. Same message the auger setting started flashing and would not perform. another jam? Again i had to keep the vibrator running to have any decent spread before the clogg. Any suggestions or help would be much appreciated.
     
  2. OC&D

    OC&D PlowSite Veteran
    from Earth
    Messages: 3,064

    Call your dealer and have them fix it under warranty.
     
  3. phil7712

    phil7712 Junior Member
    from boston
    Messages: 5

    any idea what the proplem could be?
     
  4. OC&D

    OC&D PlowSite Veteran
    from Earth
    Messages: 3,064

    Probably some issue with the controller, but since it's brand new and you have a warranty, why beat yourself up trying to figure it out?
     
  5. phil7712

    phil7712 Junior Member
    from boston
    Messages: 5

    just dont want to loose the machine for a couple weeks while i get the run around from the dealer. hoping its just a quick fix that i can handle.
     
  6. ALC-GregH

    ALC-GregH PlowSite.com Addict
    from pa
    Messages: 1,132

    Well, you already paid a pretty penny for it. If the dealer is a pain then why did you buy from them? Take it back and have them fix it. What makes you say it will be weeks? Did you call them and ask? If I just bought something brand new and it had problems, it's going back to get fixed or replaced. I'm not going to wait for a stranger to try and figure out whats wrong.
     
  7. framer1901

    framer1901 Senior Member
    Messages: 813

    1) I think everyone runs the vibrator 100% of the time in this spreader - we do with 100% salt.

    2) There are baffles at the bottom of the hopper, you can adjust them - different settings for different material. I would think that wet material would compact (jamb) more than dry material - baffles closed verses open.

    3) Your dealer sells these things, your dealer should alway be your first call for a problem. They are right there and can have eyes on the issue and experience with material you spread - we use zero sand in this area.

    4) Search function - that spreader has been around and discussed for years - you'll find more reading than you'll have time for.
     
  8. phil7712

    phil7712 Junior Member
    from boston
    Messages: 5

    ok thanks for the advice