1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help, tower won't raise on Smarthich2

Discussion in 'Boss Plows Discussion' started by G-rott, Dec 8, 2007.

  1. G-rott

    G-rott Junior Member
    Messages: 19

    Pulled up to the plow to hook up tonight, controller in float down, check. Power and controller wires connected, check. smart switch on tower up, nothing...re-check plugs, good, smart switch up, nothing. Smartswitch down motor runs...

    Remove cover...no loose wires, black wire connected per diagram. ground seems good.

    What do I check? can't even go to the dealer with it. Can't get it on the truck. Gota plow over the weekend.

    Thanks Garett
     
  2. 92XT

    92XT Senior Member
    Messages: 343

    wiggle plugs wiggle plugs D I E L E C T R I C GREASE
     
  3. G-rott

    G-rott Junior Member
    Messages: 19

    .. still nothing

    Bad switch? Vave?
     
  4. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    You can get the plow on the truck if ya need it. Just flip you pins on and push the tower up manually. As far as a problem the other guys have hit the nails right on the head.
     
  5. G-rott

    G-rott Junior Member
    Messages: 19

    Thanks for the help getting it mounted. How should I test the switch and valve before I have to start replacing parts. When are the valves magnitized? Open or Closed? Is each different?

    Thanks again

    Garett
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If the pump runs in the "lower" position, but it doesn't run with the switch in the "raise" position, then it's either a loose wire or bad connection on the switch or the plug...or the SH switch is bad..
     
  7. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,556

    not everything can be fixed with grease
     
  8. snowsniper1

    snowsniper1 Senior Member
    Messages: 239

    most likely your problem is your blade was not grounded to your truck. move your blade around while someone hold up on your switch i bet it will work
     
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it needs to ground through the blade, then something is definitly wrong...:D
     
  10. Indy

    Indy Senior Member
    Messages: 704

    I had my plow serviced in Oct and the shop said the smart hitch 2 switch went bad>?? Since then I have had is lower but not raise. I found that if I clean the + - Cables on the truck side, I get a better connection and it raises fine. Make sure your hand held is secure in the truck, if you shake the truck during mounting and it falls on the seat THE BLADE WILL MOVE (yep mine did) Angeled left and I was clear of it but it got my attention!! Best of luck

    Mike C
    Indyplower
     
  11. G-rott

    G-rott Junior Member
    Messages: 19

    Thanks

    Thanks Mike,

    I had been raising the tower by hand this week, yesterday I tried the switch and it worked?! I had re-cleaned everything and put anti-corrosion compound on everything before I put the cover back on but it didn't work then.

    It must be a connections in the wires or switch? If we don't get snow this weekend I will look at it again.

    Garett
     
  12. StratfordPusher

    StratfordPusher Senior Member
    Messages: 951

    In Float Mode

    One last thing to check... make sure your controller in on and in float position or the switch will not work....

    Al
     
  13. 92XT

    92XT Senior Member
    Messages: 343


    NEVER MANUALLY PUSH OR PULL TOWER . YOU WILL CREATE A I R POCKETS
     
  14. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,556

    :rolleyes:That is false:dizzy:


    .How or where does the air enter from?
    If air can get in fluid would be coming out:waving:

    When I remove my plow the head gear falls forward.
    To put it on I MANUALLY push the head gear up,

    NO air bubles no tiny boubles, no tiny bounles in my fluid:drinkup:
     
    Last edited: Dec 13, 2007
  15. 92XT

    92XT Senior Member
    Messages: 343

    If you would have read the manual You would know that .
    Stop posting bad information .
     
  16. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,556

    WHAT?:waving:

    Who are you talking to?
    Your post makes no sence.:dizzy:


    (insert witty come back here):drinkup:
     
  17. vog

    vog Junior Member
    Messages: 5

    switch

    had the same problem last year - it was the smarthitch switch. Usually if you have a ground problem, you'll see it when trying to plow, also. If the plow works fine after you manually hooked it up, and the switch still won't power up, it's probably the switch.
     
  18. hydro_37

    hydro_37 PlowSite Veteran
    from iowa
    Messages: 3,790

    Dang....I guess All I have in my system is AIR now. Since I push the headlight assembly up each time I hook the plow. Hey Farmer......yours full of AIR too?...lol Sure will save in Boss Fluid if I can just run air in the system. :dizzy:
     
  19. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,556

    yup, full of hot airxysport
    sure saves on fluid.I mean atf:waving:

    lol
     
  20. 3bladz

    3bladz Senior Member
    Messages: 172

    try bumping the the switch down for 1/2 sec (or less) then immediately up and see if that works.