1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HELP!!! Tecumseh 8 hp Snowblower will NOT start

Discussion in 'Truck & Equipment Repair' started by RedneckPlowGuy, Dec 1, 2007.

  1. RedneckPlowGuy

    RedneckPlowGuy Senior Member
    Messages: 120

    Well guys, storm is at my door steps and its snowing. Went out last night, changed oil in SB, filled with fresh fuel and added a cap full of seafoam. Went to fire and snowblower will NOT get fuel. Primer button feels like its not priming. Tried a small amount of ether and fuel in cylinder and still didnt fire, only popped a couple times like it was thinking about firing. What do i need to do/check to get this POS running!!
     
  2. Camden

    Camden PlowSite Fanatic
    Messages: 6,598

    You're probably going to have to remove your carb and spray it down with some carb cleaner. Those things easily get gummed up. Try that first and then see what she does.
     
  3. RedneckPlowGuy

    RedneckPlowGuy Senior Member
    Messages: 120

    is that an easy task?
     
  4. Camden

    Camden PlowSite Fanatic
    Messages: 6,598

    It should be..couple bolts, gas line and throttle cable. Just remember how it all goes together.
     
  5. RedneckPlowGuy

    RedneckPlowGuy Senior Member
    Messages: 120

    yeah, knowing where it goes should be ok, im an ASE auto technician, just not sure about all this small engine stuff, i figured i could do it, but figured id get some second opinions before i go ripping stuff apart

    THANKS CAMDEN!!!
     
  6. Solid advice:

    Years of confidence here:

    check the "Lawn Mower Repair Man"

    www.nevadawalrus.com

    very experienced in small engine repair and his website has been active
    for a number of years
    tc
     
  7. RedneckPlowGuy

    RedneckPlowGuy Senior Member
    Messages: 120

    not sure what is was but t and found a hose with a deteriorated end that i cut off and put back on. Runs kinda crappy but its goin now anyway, i think everything was gummed up like you said, hopefully the seafoam will fix that