1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help someone!

Discussion in 'Western Plows Discussion' started by raMpLOW, Feb 5, 2014.

  1. raMpLOW

    raMpLOW Junior Member
    from 60638
    Messages: 5

    I have a problem with my plow, the plow goes up and that's it but won't go left or right or down. Does anyone know if the solenoids on the plow could be back is there a way of testing them or could it be just something else!?
     
  2. fhafer

    fhafer Member
    Messages: 66

    Make, model?
     
  3. raMpLOW

    raMpLOW Junior Member
    from 60638
    Messages: 5

    Western, unimount pro series
     
  4. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Sounds to me like you have a controller or valve electrical problem. Goes up but not down, left or right. Up means S3 valve works, no down means S1 doesn't work, no right means S2 does not work, no left means S2 does not work as well. So you either have two bad valves, wires disconnected or a bad controller. Do you have a friend with a controller you can borrow that fits? This would easily eliminate one possibility. You can also pull the valve cover off and ensure that all three coils have both wires attached. The colors are marked on the inside of the valve cover.
    Tell us more about it. I don't know these old unit names, did Pro Series come as Flowstat or Isarmatic? Is the lift ram part of the hydraulic unit or do you have a separate ram for lift, not integrated? How many plugs at the grill, two or three? Still has original relays to switch lights or does it have an isolation module?
    Tell us what it is and we can link you to the mechanic's guide so you can do some logical testing.
     
  5. raMpLOW

    raMpLOW Junior Member
    from 60638
    Messages: 5

    Thanks but it end up being a bad connection one of the valves! It's a isarmatic set up! But thanks for all the help really help!