1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help Show me the Light

Discussion in 'Hiniker' started by Greenery, Oct 26, 2008.

  1. Greenery

    Greenery 2000 Club Member
    Messages: 2,380

    Ok my new to me c-plow is having lighting difficulties. When I looked at it at the dealer they hooked it up to a truck they had and everything worked. Now that I installed the used wiring I got with it in my truck everything works but the headlights neither low or high beam the turn signals and parking lights work fine though. Also the truck lights function normally there off when switched to plow and on when switched to truck. Could it be a bad relay or ????

    Oh yeah I should add that when the plow is not attatched to the truck the headlights stay on no mattter what position the switch is in but they do turn on and off when the plow is attatched. Thanks in advance for any help you guys can give me.
     
    Last edited: Oct 26, 2008
  2. bigearl

    bigearl Senior Member
    Messages: 393

    Defenanatly a bad relay or there is a bad ground in the relay. I will take a pic of mine to show what I did.
     
  3. tripper

    tripper Junior Member
    Messages: 10

    Could be that a plug on the light adapter kit is pluged in backwards or wrong light adapter kit.