1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help Quick please

Discussion in 'Ford Trucks' started by SteveR, Mar 31, 2010.

  1. SteveR

    SteveR Senior Member
    Messages: 252

    My 2000 SD has an issue....When you shut off the key the heater blower still runs. Sometimes the radio stays on as well. On occasion there is a weak series of beeps from what sounds like the chime. My mechanic is thinking GEM module. Any thoughts??
     
  2. smoore45

    smoore45 Senior Member
    Messages: 526

    I would agree that the GEM is a good place to start. With these weird electrical problems, it take a couple of trys to get it right. You may also want to check the grounds going to the GEM, Battery Junction Box and any of the other fuse boxes that contain relays(especially under the hood where there is more corrosion) . Either some relay is burnt out/stuck OR a ground is going bad to one of the modules. :mechanic:
     
  3. Plowtoy

    Plowtoy Senior Member
    Messages: 929

    My buddy has the same truck and had the same symptoms as you, it was the gem cell the dealer replaced. They also told him that those trucks had windshields leak and the water would run down the fire wall and onto the gem cell. Make sure that you have that checked when/if you replace the gem