1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

help please unimount turns right when you lower and motor stays running till you rais

Discussion in 'Western Plows Discussion' started by nvmy55, Dec 26, 2009.

  1. nvmy55

    nvmy55 Junior Member
    from chicago
    Messages: 3

    plowed 3 driveways today and on the 4th i went to lower the blade and instaed it angled right and wouldnt stop till you raised it please help fast 10 inches here today
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Bad controller most likely. Not at all uncommon. Try or borrow a spare controller.
     
  3. snow man 0311

    snow man 0311 Member
    Messages: 66

    try to clean the contacts in the plug .My does the same thing sometimes , I wiggle it and sprey some dielectri c spray and it fine ..Try this first , hope this helps.
     
  4. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    try (or have some one) wiggling the harness were the vehicle and plow connect together while trying to lower the blade. If it stops ( angle right) you have a bad connection.

    Also check the wires to the S valves. white/yellow goes to S2 valve (closet to the motor) which control "lowering the plow. light green wire goes to S3 valve which control the right angel (next to S2 valve) to make sure they are not loose.

    Or like B & B said it might be a bad controller. You can also do a controller test.

    Here is a diagram

    contest.jpg

    more snow coming

    contest.jpg
     
    Last edited: Dec 26, 2009
  5. nvmy55

    nvmy55 Junior Member
    from chicago
    Messages: 3

    ok tried controller swap not that cleaned and tightened plug conection no good
     
  6. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    check and remove the S valves. Might have foreign material inside one of the channels

    diagram
    carttest.jpg

    you can test them as well.....

    carttest.jpg
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If the pump runs and the plow angles even with the control in the neutral or down position and swapping controllers didn't fix it then you have an issue in the control harness.

    Sticking valves won't cause the pump to run continuously.
     
  8. nvmy55

    nvmy55 Junior Member
    from chicago
    Messages: 3

    thanks all for your help

    after all of that the harness was chaffed at the firewall and shorting 2 wires thanks again guys all your help was greatly apreciated