1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HELP!! Meyer Plow light problem Nite Saber

Discussion in 'Commercial Snow Removal' started by golfmanres, Feb 28, 2005.

  1. golfmanres

    golfmanres Senior Member
    Messages: 150

    Help please. I have a meyer st7.5 setup on my Chevy 1998 k2500hd.

    I am having a problem finding the problem. The left side plow light is not working on low beams. I have changed the bulb, and now spent 50$ on the truck/ plow light module that is for the Day time running lights. That wasnt the problem. It says on the module that their is an internal fuse that can go bad so that is why i changed it, But no luck. The high beams work fine. The right side works fine also. Its just the low beams on the left side dont work. What can be the problem. Does anyone have the wiring diagram for the meyer nite sabers? I lost mine and I am have trouble finding the number to talk to someone at meyer to get one. Please any help would be greatly appreciated.

    ERIK
     
  2. fernalddude

    fernalddude PlowSite.com Addict
    Messages: 1,105

  3. golfmanres

    golfmanres Senior Member
    Messages: 150

    Thanks but that site is coming up for the pump only, cant find any inforamtion on the lighting that i need. I am in need of the wiring diagram. I have a hell of a problem with this lighting set up.

    Now with the new light module the truck headlights are acting weird. So i put the old one back on and the truck lights are ok, but still have problem with the plow lights. Still Need HELP PLEASE!!!
     
  4. Young Pup

    Young Pup PlowSite Fanatic
    Messages: 5,487


    I had the same problem with mine. And it was the change over module. Where did you get the replacement at? Take it back and try another one.Take the truck with you. Now my turn signal will not work on the side that I replace the module on. Raining outside so I am not that worried about the turn signal right now.

    JP
     
  5. Young Pup

    Young Pup PlowSite Fanatic
    Messages: 5,487

    I forgot to put this in. Make sure you clean all the connections from the plugs. Mine were totally corroded.
     
  6. golfmanres

    golfmanres Senior Member
    Messages: 150

    Jp. Do you still have the wirign diagram for your setup?
     
  7. Young Pup

    Young Pup PlowSite Fanatic
    Messages: 5,487

    No I don't. I actually went to the dealer and they walked me through what I had to do. Sorry. Will double check to see about the diagram but I am 100% sure I never had it.

    JP
     
  8. jpunlimited

    jpunlimited Senior Member
    Messages: 132

    try this

    1.clean and insert an ice pick or all in the main plug pins. expand them a little!!!! then plug in and try.
    2.still no go? I believe you can bipass the module all together plug the meyer lights directly to the vehicle harness.
    3.still no go check the ground for that side it comes off the "b" plug.
    4.still no go Private message me your fax number and I will fax over the original instructions and diagram.
     
  9. Young Pup

    Young Pup PlowSite Fanatic
    Messages: 5,487

    No diagram here have you had any luck yet?

    JP
     
  10. golfmanres

    golfmanres Senior Member
    Messages: 150

    Well so far i am going to use the regular truck lights till it gets nicer outside. Meyer told me that i will have to replace all the wiring for the plow on my truck to fix teh problem. Thats a 200$ fix. Well they told me with the MDII system with the huge molded plug that it some times goes bad with the connectors on the inside and no way to fix except by the new harnesses. Not sure i like that fix but i will see. I was able to jiggle the plug and the light came on for a second. So i think that is the problem and that i have no other choice. I will let everyone know the out come and if anyone elsse knows of a different fix please let me know. Also i havent totally isolated it down to the plug but who knows i might be geting closer then i was this morning.
     
  11. Young Pup

    Young Pup PlowSite Fanatic
    Messages: 5,487

    Not what I wanted to hear. I have the mdII too.

    When did you get your setup? I got mine in Dec 03. When I went to the dealer he gave me my new module and a light at no charge. Wonder if the new harness is covered as well.
     
    Last edited: Feb 28, 2005
  12. 04 chevy 2500hd

    04 chevy 2500hd Junior Member
    from pa
    Messages: 1

    md ll

    hi golfmanes you can bypass that huge plug follow the wires from the modules to that huge plug and disconnect it and plug right into the lite instead,,,,,Doug
     
  13. DP Property

    DP Property Senior Member
    Messages: 158

    I had the same problem the other day. I sprayed the plugs with fluidfilm that plug into the modules and the problem is now fixed. I plugged them back in and all the lights are working now.