1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help its broken!!!!!!

Discussion in 'Truck & Equipment Repair' started by ArcticTahoe, Dec 7, 2010.

  1. ArcticTahoe

    ArcticTahoe Junior Member
    Messages: 14

    I have a 7' 6" arctic with underhood pump when it will only angle left and when i lift up it angles full left then goes up any ideas?
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    one of the valves is stuck. see which one has power for up. that is the one i would start with.

    post a pic of your power unit. you may be able to shift the valve with a small screwdriver if it is the one i think it is.
     
  3. ArcticTahoe

    ArcticTahoe Junior Member
    Messages: 14

    ok thanks will post a pic asap hopefully i can get it fixed were gettin dumped on here
     
  4. ArcticTahoe

    ArcticTahoe Junior Member
    Messages: 14

    Do you have an email no lead I'm on my black berry so I can't upload a pic but I can send them through email
     
  5. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

  6. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    that is a monarch pump. the valves are internal on that unit. i can put you in touch with monarch if you like. that pump is tricky to fix if you don't know how it works. make sure all of your power wires to the valves get power at the right time. if so i would lean towards valve issue.

    http://www.masondynamics.com/

    call these guys. they will point you in the right direction. tell them kip hurd said to call them and they will help you.
     
  7. ArcticTahoe

    ArcticTahoe Junior Member
    Messages: 14

    That's great thanks alot
     
  8. ArcticTahoe

    ArcticTahoe Junior Member
    Messages: 14

    Thanks kip they were very helpful gave me a full breakdown of the power unit and how to repair the stuck vavle its an easy fix and they were very helpful thanks again.
    Cheers Rick
     
  9. ArcticTahoe

    ArcticTahoe Junior Member
    Messages: 14

    turns out it was a switch replaced it works great noweasy fix thanks to the trouble trree and common problem sheets i recieved from mason dynamics...