1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HELP!!! Isolation module, Loud Noise

Discussion in 'Truck & Equipment Repair' started by alliance10, Dec 20, 2012.

  1. alliance10

    alliance10 Junior Member
    Messages: 4

    went to hook the plow and truck up today in prep for the storm and the 3 port isolation module is emitting a loud buzzing noise and stops when the A is unplugged, Its snowing and i need help! Please


    2011 2500
    1 yr old 8.5 western mvp pro plus 2 plug
  2. alliance10

    alliance10 Junior Member
    Messages: 4

    i have functioning lights but no plow power,
  3. LON

    LON Senior Member
    Messages: 749

    Solenoid go bad? Had that happen to a Xtreme V.
  4. alliance10

    alliance10 Junior Member
    Messages: 4

    no selonoid, in a 3 port 2 plug western.
  5. D&JsLawn

    D&JsLawn Member
    Messages: 79

    Yes there is, its under the cover on the plow.
  6. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,238

    Where is the noise? does the controller light up?
  7. mcwlandscaping

    mcwlandscaping 2000 Club Member
    Messages: 2,557

    Make sure you have a full 12v connection (check it) to the red wire in the cab for the controller. I had an issue with the connection with mine and it caused the iso module to buzz real loud. I thought i fried it but after checking that wire and making a better connection all was better!