1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help Fisher Extreme V power problem

Discussion in 'Fisher Engineering Discussion' started by snow game, Dec 7, 2010.

  1. snow game

    snow game Senior Member
    from RI
    Messages: 255

    We have a Fisher Extreme V, 3 plug new last December. Have not had snow yet this year, but some is forecasted for Fri and Sun. Problem we are having is that at times it won't work at all. all we get is a blinking power light on the remote. Other times it works fine. We have tried the plow on other trucks in the fleet and have ruled out the truck side of the plow. The problem comes and goes.
    Any suggestions would be helpful.
    We have cleaned all connectors, cleaned pins, removed and cleaned grounds, checked all fuses.
    We have two other plows that use the same set up. They are xls plows. I was thinking of taking the module off of one to try it on the v to see if that solves the problem.
    what do you think?
     
  2. tractorbill

    tractorbill Member
    Messages: 65

    Xtreme v w/3 plugs? all the xtremes I have installed in the last couple years have been 2 plug. the blinking light means that the plow is not "talking" to the controller. switching modules with a known good unit is where I would start.
     
  3. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,033

    It could be the pins on the gril connectors. My XLS had a similar issue when I first got it, you have to take a fine tip flat head screw driver and "spade" them out just slightly so they get a snugger fit.

    The other thing that comes to mind is the theft lock....I'm not sure when they started utilizing it on the XtremeV's and XLS's, but it is now available. Have you tried swapping out the controllers as there the same ones for both models?
     
  4. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,033

    Good catch, your right about the 3 plug.

    A loose connection anywhere can also cause the system to act like that. They never did cure my old system (unrelated symptom), and a few of the guys have ventured it was the module all along.
     
  5. snow game

    snow game Senior Member
    from RI
    Messages: 255

    Sorry about the typo, they are all 2 plug systems. I will try opening up the spades on the plug, if that doesn't works I will try switching the modules. I don't think its a problem in the controller because we have the same problem on both trucks and the xls plow works fine on both trucks.
    Repo man what is the theft switch thing you mentioned?
     
  6. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,033

    It's a new technology thing where individual controllers can be linked to the plow module's, thus if someone attempts to operate your plow with their truck and controller, it will not work without the code. The HTS was introduced with it, the rest of the multiplex plows are now following suit.

    Here is a video (scroll through the videos until you see "Security Guard") that better describes it. I'm not sure on the particulars as to WHEN it was implemented on the XLS and XtremeV's.
     
  7. snow game

    snow game Senior Member
    from RI
    Messages: 255

    Tractorbill Thank you! youe were correct. the module was bad, plow went under water in spring floods, replaced module for 166.00 and all is working fine, hope thats the end of my water troubles.
     
  8. tractorbill

    tractorbill Member
    Messages: 65

    Glad it worked out, modules and water are not a good mix.As for the security system you have to program a code into it to activate it, otherwise its dormant.