1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HELP!! Boss plow hazard/turn signal lights stopped working

Discussion in 'Boss Plows Discussion' started by bsuds, Dec 19, 2011.

  1. bsuds

    bsuds Senior Member
    Messages: 192

    I have a 2007 classic chevy with the 6.0 gas engine, and run a 7.5 super duty Boss straight blade. The plow has been hooked up since 2008 on this truck without any issues. The last storm the hazard lights on the plow worked fine, and today while I was out shoveling I noticed the flashers were not working on the plow, but they were flashing on the truck at both the front and back of the truck. It is strange that the flashers/turn signal lights are running on the front of the truck, but not on the plow. The headlights on the plow work fine, it is just the flashers/turn signal lights that are not working. Usually the truck hazards at the front end of the truck do not operate while I am running the plow lights, so I am at a loss as to why the front truck hazards would flash, when it is the hazards on the plow that should be flashing. All help is appreciated!! :mechanic:
     
  2. ihdriver7088

    ihdriver7088 Senior Member
    Messages: 315

    check wires that are spliced into the trucks harness may have simply came unplugged
     
  3. jklawn&Plow

    jklawn&Plow Senior Member
    Messages: 469

    I haven't quite develped a schematic for the turn signals, but I am pretty sure that normally both sets of marker lamps work at the same time (truck and plow). When I connect my plows with the Switch in the truck set to "Truck" not plow, the marker lamps on the plow light up. Where the r4 or 5 relays choose between either plow or truck headlights, for the turn signals the other relay near the headlight (Headlight adaptor) doesn't have a connection on 87A so its not choosing one or the other. I would see if you have the signal at the connector to the plow and work your way to the light start at the light and work your way back.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The trucks hazard/turn/markers are not disabled by the plow, if they don't work when the plow is connected you have a rather major issue going on there.

    Do the plow marker lights work?
     
  5. bsuds

    bsuds Senior Member
    Messages: 192

    No the flasher lights do not turn on at all, but the headlights on the plow work. I did about 4 hours of plowing tonight, and the plow operated fine. The plow goes up, down, and angles left, right. It is just the marker lights that quit working. The marker lights were working durimg the previous storm, but it was tonight that I noticed they were not working. I hope this is nothing major, we have another storm coming in thursday.
     
  6. bsuds

    bsuds Senior Member
    Messages: 192

    B&B when you say I have a rather major issue going what could be happening?
     
  7. rdoughty

    rdoughty Junior Member
    from maine
    Messages: 3

    Just an idea, check the ground where it connects behind the headlights. My ground went bad and I lost my marker light and my blinker on 1 side.
     
  8. sailorman3

    sailorman3 Member
    Messages: 38

    This may sound stupid, but if the marker and flashers are working on the truck but not the plow, check the bulbs. It is posible that both may be gone. Start at the simple stuff first. Then look at the plugs in the harness to see if they are loose and clean. (no corrosion)
     
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You need to be more clear with your terminology. You have no lighting on the plow side what so ever except the headlamps, correct? In other words, no turns, no flashers (same thing) OR marker light functions?
     
  10. bsuds

    bsuds Senior Member
    Messages: 192

    The lights that work on the plow are the high and low beam headlamps. But none of the light flashers located just under the headlamps on the plowside work at all. So the only plow lights that work on the plow are the high and low beam.
     
  11. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,628

    Are the marker lights and signals still working on the truck? If not check the truck fuse.
     
  12. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Ok then it's most likely a plow side ground issue. All functions in the amber lights (turns, markers, flashers) share a common ground lead down to the motor ground. It's a brown wire. So pull the pump cover and check it and it's connection.

    You can pull either of the light housings apart and check for ground in there first but I doubt you'll have it anyway. As the only way you lose all lighting functions in the ambers is if they lost their ground.
     
  13. bsuds

    bsuds Senior Member
    Messages: 192

    I tested the brown wire behind the light housing and got no signal. So I will investigate further to see where the ground is loose in the pump housing.
     
  14. bsuds

    bsuds Senior Member
    Messages: 192

    I checked the ground inside the pump housing and the ground is fine in there. So what does this mean? Is there a cut in the wire somewhere between the pump and the light, and what else will this effect? How do I have head lamps but no marker lights?
     
  15. rdoughty

    rdoughty Junior Member
    from maine
    Messages: 3

    On my 07 the marker lights only ground to a little brown wire that goes behind the headlight housing. It was very corroded and broke off in my hand, have not seen both sides go at once but easy to fix....
     
  16. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Because the head lamps have their own dedicated ground directly from the truck, while the ambers are only grounded at the pump ground.

    Pull one of the ambers apart and check the brown for ground in the housing. Probably won't have any, which means it's somewhere between where the left and right lights splice together in the plow harness and down to the ground terminal on the pump. Same wire I mentioned previously.
     
  17. 90w250mm

    90w250mm Member
    from indiana
    Messages: 42

    double check the bulbs, if the bulbs are burnt and or not seated good in the housing you wont get anything. I just went through this on my 8'2"poly v. I replaced all four bulbs and tada I've got everything