1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HELP! Blade keeps staying in up position.

Discussion in 'Blizzard Plows Discussion' started by skidz38, Jan 27, 2011.

  1. skidz38

    skidz38 Junior Member
    Messages: 1

    I need some suggestions about my issue. I have checked all connections (good) and all fuses (good).

    My issue is very time I turn the blade left or right, it creeps up 2"s every time. It will go all they to the highest point. Then, the blade will not lower. Stuck in up position, but all other functions work.

    Second issue, when the blade does move down it is extremely slow.

    Bad thing is now, I'm losing time tonight for plowing.

    I appreciate any help or suggestions.

    Thanks.
     
    Last edited: Jan 27, 2011
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Here's my theory: Something (H20, ice, shorted wire) is energizing the white wire, keeping it energized, thus every time you engage the pump, it lifts. In addition, diode might be fried. The White lift wire is between the + and - in the main plug, I've seen harnesses get hot there and melt the rubber around the terminals. Or ice/moisture in the plug could be the culprit.

    Other school of thought would be to check your lift and float valves and coils.