1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help 4-5 year old ultra pro

Discussion in 'Western Plows Discussion' started by awagner9, Jul 18, 2008.

  1. awagner9

    awagner9 Member
    from NW Ohio
    Messages: 30

    I bought a dodge with a ultra pro on it. Plow came with yearly service records. It has 2 wires. The plow was placed in the bed of the truck for transportation. all the oil leaked out due to the plow being blade down. I got home unloaded it. I let it sit for a few days in proper position. I hooked the plow up and filled it with oil and it would not work. You can hear the stater just spin. If you play with it for awhile it will raise real jerky. If you let it drop it will raise more. My buddy thinks its the starter. Is this the problem? Or is it the wrong oil or air in the pump? Please help!!!!!!!!!!!!
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Sounds like air in the system. Either it still isn't full of fluid or it still has a bit of air in it. One other possibility is that the pickup tube in the reservoir fell off during transport (had that happen before on a face down transported Western).

    What for fluid did it have in it? And what did you replace it with?
     
  3. awagner9

    awagner9 Member
    from NW Ohio
    Messages: 30

    Western oil was in it. All leaked out. Put snow plow oil from TSC. Only thing I could find. Gonna drain all of it and replace with dextron III. How hard is it to reattach pick up tube?
     
  4. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    well i could take a guess...... let me ask you this

    If you lower the plow to the ground, will it move side to side ok?

    if you raise it, then the probelm starts?

    I had a plw , its 5 yrs now... and the first year i had a similar problem... turned out the filter along with the sucktion tube was not installed properly and had simly falen off... thus when u raised the plow and the fluid level droped in the resivor, the pump began sucking air.... when u lowered the plow.... the fluid level returned and could then move the plow side to side correctly
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Do a search here in the Western forum...you'll find plenty of reading on the pickup tube issues/solutions.
     
  6. awagner9

    awagner9 Member
    from NW Ohio
    Messages: 30

    Thanks!!!!!!!! Took off the res. pick-up tube was in the bottom. Put it back in place and back togehter and works like a champ. Now time to sell.
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Good deal! :drinkup:

    The pickup tube issue was/is a bit of the Achilles heel for the Ultra's for a while, and one still crops up from time to time. Western did release a retainer kit to address this very issue.
     
  8. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    y the sale?
     
  9. awagner9

    awagner9 Member
    from NW Ohio
    Messages: 30

    2002 Not a true four door. Quad cab does fit the family. Don't like driving up against the steering wheel.