1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

HELP! - 2010 F150 SCREW - K2 Everest Plow (Snowbear type)

Discussion in 'Ford Trucks' started by krazycanuck2011, Dec 13, 2013.

  1. krazycanuck2011

    krazycanuck2011 Junior Member
    Messages: 2

    Hello all I just purchased and installed a Snowbear type plow, copy so to speak from Costco here in Canada. Anyhow I've tested the plow controller box, the entire setup on my F150 truck battery without any of the other connections to the truck hooked up, essentially the wires to the battery from the plow controller box only, I used the switch, the plow goes up and down fine. When I hook the truck wiring up, ie positive and negative cables, the truck allows the blade to go up with the winch but not down. I am totally lost, I've been fooling with the electrical all night, I am trying to get this figured out before a storm hits here on Sunday which is going to drop 2-3 feet of snow.

    Truck is a 2010 Super crew 5.4L XLT ( XTR here in Canada ). I just bought and installed a new 1000 cca battery. It has been charged to max as well.

    I would appreciate any and all feedback to help resolve this, there is nothing wrong with any of the plow equipment, it appears to be something with the truck? Maybe some sort of protection built into the f150? Do I need to do some sort of isolation on the truck harness from the plow controller box?

    This plow is exactly the same as a snowbear just rebranded. The instructions are even the same.

    Again thanks, I really need help!

    Mike
    Krazycanuck2011
     
    Last edited: Dec 13, 2013