1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

help! 2006 MM1 wiring

Discussion in 'Fisher Engineering Discussion' started by karimdurham, Sep 25, 2015.

  1. karimdurham

    karimdurham Member
    Messages: 31

    I have everything done except the control red wire to the fuse. 2006 F250 SD. anyone have a specific fuse # I plug into? I am running it on drivers side under dash or should it be in a different fuse box.

    Thanks
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Ignition hot circuit.
    Look into fuse taps as well. Helps with adding a "circuit"
     
  3. karimdurham

    karimdurham Member
    Messages: 31

    I am a noob so you might as well speak Chinese :)
     
  4. karimdurham

    karimdurham Member
    Messages: 31

    In all seriousness. Thanks for the reply
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

  6. karimdurham

    karimdurham Member
    Messages: 31

    Great thanks!

    What about adjustable pedals with a 15 fuse?
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    As long as it's not on while the key is off
     
  8. karimdurham

    karimdurham Member
    Messages: 31

    New wiring install 2006 F250 problem!

    I installed the wiring for MM1 and I have headlights and parking light working, but no turn signals! Amy thoughts?
     
  9. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,534

    Who's Amy?

    Do the hazards work?

    Did you verify the correct wires you are connecting to?
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Did you tap into the trucks turn signals? I believe the pass side is grey, and the drivers side is purple. That's the plowside colors btw
     
  11. karimdurham

    karimdurham Member
    Messages: 31

    I put purple to light green on turn. When I turn lights on blinker bulb is lite with headlight.

    I put brown to brown on parking light and there is no light at that bulb!

    Ugh!!!
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Do you have a GOOD ground at the blk/og wire?
    Do you have GOOD contact inside the parking light sockets?
    If your in doubt about your grounds, add a wire from the trucks negative post to that socket, if it lights up bright.....ground issues.

    You never mentioned the pass turn wire?
     
  13. karimdurham

    karimdurham Member
    Messages: 31

    What is a pass turn wire? Sorry noob here
     
  14. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    The wire that you splice into on your truck to flash the passenger side light on the plow. Should have been a loose wire in the plow harness going to the passenger side of the truck
     
  15. karimdurham

    karimdurham Member
    Messages: 31

    Yes that is the purple to white/blue on passanger side.
    I spliced purple to green/white on drivers
     
  16. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Not sure if your trucks turn and parking light wiring so I can't answer that.
    Do that ground tip and see if that helps
     
  17. karimdurham

    karimdurham Member
    Messages: 31

    The big ground cable from harness, I have attached to the negative terminal.

    Black/orange goes into some connecting plug then O grounded that
     
  18. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    WHOA there should only be one purple. Not 2. You need the wiring diagram.
     
  19. karimdurham

    karimdurham Member
    Messages: 31

    One purple for each side
     
  20. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Nope.....one purple one side.