1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Headlight Trouble

Discussion in 'Ram Trucks' started by PlowMan03, Nov 7, 2007.

  1. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 471

    Well I just put in a set of Sliverstar headlights and I went to go try them out and the passengerside light was working the driverside wasn't, I found the problem broken wire and I put a wire connector on it and the light is really dim and the other is bright. I put in the old one and that too is dim compared to the new one. Have any ideas what the problem might be?

    I am about ready to blow this darn thing up and go out and get me a real truck like a Chevy or GMC!
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Sounds like you still have a bad connection somewhere..I'd check the ground wire real close. Check the resistance across the connector pins with a DVOM (low and ground together, Hi and ground together) Then check from the ground pin to a good ground source on the truck...anything over about 1 or 2 Ohms is too much..

    DAYTONA Z Member
    Messages: 53

    Check the fuses in the fuse box under the hood. On my 2000 Ram I blew several fuses while working on the plow lights . FYI. right and left have a seperate fuse. The headlight will dimly light even though the fuse is blown.

    Hope that's it it drove me nuts for a while also.
  4. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 7,921

    I agree,:nod:
    I had a similar problem with my 01
  5. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 471

    Thanks for the responces guys. I'll try Daytona Z's theory tomorrow to see if thats the trouble or not.
  6. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 471

    Well I checked the fuses yesterday and those were fine. I'm gonna try putting the old lights back in and see if that does anything or not, if not I'll just have to deal with it I guess.