1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Headlight problem

Discussion in 'Chevy Trucks' started by Ant118, Dec 4, 2013.

  1. Ant118

    Ant118 Senior Member
    Messages: 184

    Well its not really and issue just drives me nuts. Last year I got my harness installed at the local western dealers. Now ever since he installed it my High beam lamp on the dash is on with it actually being low beam that is working. But if I pull the stick to activate high beams the high beams come on and the high beam indicator goes away on the cluster? Im figuring it has the be the wiring from the plow harness? Any ideas
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,005

    Did they install the high and low beam connectors in the wrong lights?
     
  3. buddymanzpop

    buddymanzpop Senior Member
    Messages: 601

    Three port or four port isolation module? Why didn't you bring it back to the installing dealer if it was never done correctly?
     
  4. Ant118

    Ant118 Senior Member
    Messages: 184

    It's a 3 port ABC module. Well I was away in Europe for the summer. I had my father pick it up for me. Just been so busy to go back.
     
  5. buddymanzpop

    buddymanzpop Senior Member
    Messages: 601

    Look at the female plugs on the Fisher/Western head light harness that the vehicle head light harness male plugs go into, those female plugs have the letters "A" on one side and "B" on the other side, make sure the clip from the male plug that keeps the connection fastened is all on the same lettered side. Check both high and low beam connections on both sides as they are all reversable.
     
  6. Ant118

    Ant118 Senior Member
    Messages: 184

    thanks ill look at it tonight. ill let you know what i see.