1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Headlight not working

Discussion in 'Western Plows Discussion' started by PremierSnowPlow, Feb 29, 2016.

  1. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    Just got my mvp plus hooked up today. I have a drivers head light out, replaced bulb and still doesn't work. Switched ports on my module and didn't help either. Anybody have any issues like this before? Have a potential storm hitting tomorrow night so I want to rectify the issue and get it fixed before I have to plow. The lights are the western nighthawks
     
    Last edited: Feb 29, 2016
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,638

    What truck?
     
  3. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,517

    Judging by the pic, 03 Ford SuperDuty with 7.3.
     
  4. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,517

    Broken pin on plowside harnesses, have you test lighted anything?
     
  5. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    Haven't done anything, hooked it up, seen bulb wasn't working, bought new one, replaced and walked away when I noticed the bulb wasn't blown.
     
  6. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,638

    :help: I know my eyes aren't that bad.

    OP unplug the plow wires at the grill, do the truck lights work?
     
  7. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    Kimber, just checked and my driver side headlight on my truck also doesn't work when the plugs aren't plugged in.
     
    Last edited: Mar 1, 2016
  8. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,569

  9. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    I have this connector that I can't find anything to plug in to. It's on the adapter that I had to buy to use my 4 port iso with 2 plug setup.

    [​IMG]
     
  10. lawns4life

    lawns4life Member
    from mi
    Messages: 77

    Headlight fuse is out on truck..
     
  11. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    . Wouldn't that cause both headlights to not work
     
  12. UltraLwn&Lndscp

    UltraLwn&Lndscp Senior Member
    Messages: 138

    I am not familiar with Ford, but My GM trucks have a separate fuse for each side. I would imagine Ford would be the same.
     
  13. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,517

  14. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    Thanks I'll check in the am
     
  15. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,569

    I think you have had every one of us on the ropes once or twice... :dizzy:
     
  16. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,517

    Well, PS is like a puzzle. Nobody ever gives the whole story.
     
  17. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    Just checked the fuses on the adapter and the are both good. My high beams work, but low beams my driver side light is out on the plow and when I unhook it the headlight is also out on the truck.
     
  18. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,517

    OK, in the truck fuse box, did u check them?
     
  19. Western1

    Western1 Senior Member
    from MI.
    Messages: 677

    Looks like you're missing the configuration plug on that connector. Just a little jumper plug that connects the middle terminal to one or the other outside terminals. You can make one to try it. I'll try to post a link.
     
  20. PremierSnowPlow

    PremierSnowPlow Senior Member
    Messages: 125

    Did not, I'll check them later.