1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Headlight issue on plow

Discussion in 'Western Plows Discussion' started by Captainjack, Jan 12, 2012.

  1. Captainjack

    Captainjack Junior Member
    Messages: 13

    I have a 2003 Chevy 2500HD and a Ultramount 3 plug ISO. Low beam plow light on drivers side does not come on. High beam works fine and truck headlights work as they should. Switched bulbs to verify bulb works ok and it does. All parking and turn signals work as well. Any ideas/comments/suggestions? Thanks
     
  2. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Is this on a new install or did all the headlights work at one time? Chevs have an issue with the original truck headlight plugs being wired randomly. That is to say, since there are only two wires on each bulb plug they don't care at the factory which wire goes in which side. That means that you have to look for the common colour on each plug to find the common wire. One wire to each of the four bulbs will be the same while the second wire to each plug is a different colour. Make sure the original headlight plug (that now goes to the western headlight harness) is oriented so that the common wire is aligned with the western wire labelled common. If these are not right then the truck lights will work but the plow lights will not. It's a 50 50 thing if you don't look for it.
     
  3. Captainjack

    Captainjack Junior Member
    Messages: 13

    This is a new install. Older Ultramount with upgraded wiring for 3 plug system. All new wiring on truck and plow. Will check the wiring and let you know. Thanks for the help.