1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Headlight issue! 2000 f250

Discussion in 'Fisher Engineering Discussion' started by abbe, Sep 15, 2011.

  1. abbe

    abbe Senior Member
    from RI
    Messages: 719

    Hey guys, i installed my 3 plug harness about 3 years ago. i put everything in myself and it has all worked flawlessly the last few years. About two weeks ago i see i had a headlight out. so i bought new bulbs and replaced them. Problem is the light is still out. High beams will work. but just regular headlights has the passenger side out. I checked and the configuration plug is still in. Any thoughts? im 99 percent sure its got to be something with the fisher wiring. Could a dirty truckside plug cause this? i havent thought of cleaning it, but i did pickup a plow with a ton of die electric in the plug? thanks guys
     
  2. abbe

    abbe Senior Member
    from RI
    Messages: 719

    nobody has an idea?
     
  3. s. donato

    s. donato Senior Member
    Messages: 314

    I would check your connections that you m ade for the plow wiring. I had something similair on one of my trucks it was just a poor connection. And could be that the wire is oxidizing.
     
  4. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    It would take 5 seconds to unplug ur fisher wiring and plug in ur factory lights then u will know exactly where to look if it works or still does not work.Had the same thing happen with mine and it blew a fuse on my truck.
     
  5. camaro 77

    camaro 77 Senior Member
    from ma
    Messages: 283

    your truck has rt and left headlight fuses check there first
     
  6. abbe

    abbe Senior Member
    from RI
    Messages: 719

    Blew the fuse guys, i checked that right after i posted this and i just forgot to check back. i have no idea why and it hasnt popped again. something funky i guess. thanks for the input
     
  7. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Np been there. Its usually from a plow with messed hedlights or headlight harness from
    my experience.
     
  8. abbe

    abbe Senior Member
    from RI
    Messages: 719

    Yeah i picked up a gaff 9' mm2 with screwed up lights that were aftermarkets spliced in, must have been the culprit