1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Headlight help needed

Discussion in 'Fisher Engineering Discussion' started by tc4400, Aug 20, 2010.

  1. tc4400

    tc4400 Junior Member
    Messages: 5

    I just bought a used MM2 RD 7.5 foot and put it on my 2003 Dodge Ram 1500. I have the plow working up/down/left/right fine. Just hooked up the Fisher recommended 29050 headlight harness and it does not switch to the Fisher Intensifier headlights. I hard wired the parking light and turn signals and they work on the truck and plow lights. I have a 29060 isolation module that came with the plow. My truck does not have DRL. The Fisher site recomends the 29070 isolation module it seems like this is for trucks with DRL. Any ideas why this stays on truck lights anf does not switch to the plow lights?
  2. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    I belive it should not matter what module u use. Are u sure u plugged in the headlight wires correctly. Its prety hard not to. Maybe the module is just plain bad since u got it used and who knows what might of happened to it.Also the plug that goes to the plow the one with the most pins make sure it is good and clean.
    Last edited: Aug 20, 2010
  3. tc4400

    tc4400 Junior Member
    Messages: 5

    help still neded

    i have the plugs set up correctly. H5 setup. Plow harness to headlights and truck lights to the harness. Blinkers work on plow lights (and truck at the sane time), but all others are truck only.

    I was able to setup and wire my 1993 Maxda B2600 with a Speedcast plow.about 4 years ago. Still works great. just want to get the 2003 Ram 2500 working so I can sell my Mazda "yard' truck. Thanks for all your help. newbee here.
  4. tc4400

    tc4400 Junior Member
    Messages: 5

    fixed it

    I got the lights to work. I had the"park" wire wrong. As soon as I fixed this everything works great.