1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Have a ? about e-60 pump

Discussion in 'Truck & Equipment Repair' started by yankeerose, Dec 29, 2010.

  1. yankeerose

    yankeerose Junior Member
    Messages: 13

    Ive been running a e47 and thought I would up grade to a e -60 So I bought the plow and pump.I saw it worked and I bought it. I ran it for about 3 hrs and it did good into the 4hr I rasied the plow and it drop on its own I lifted it and drop right away plenty of fluid and now it wont even go up with the plow hooked up . I replaced all coils no change so today I took it all apart cleaned everything Pa block and the pump but it back together and it went up it held and I let it down but now wont go back up again can anybody help thanks By the way it tries to go up but wont
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    make sure the oring is seated in the bottom of the housing.
     
  3. wva

    wva Member
    Messages: 78

    hi Ihad the same thing with mine I got a basic seal kit for smith bros parts.com $30 put it in its the packing cup on the ram and or the oring under the base of the ram easy fix meyers site has step by step how to hope this helps
     
    Last edited: Dec 30, 2010
  4. wva

    wva Member
    Messages: 78

    hi Ihad the same thing with mine I got a basic seal kit for smith bros parts.com $30 put it in its the packing cup on the ram and or the oring under the base of the ram easy fix meyers site has step by step how to hope this helps
     
  5. yankeerose

    yankeerose Junior Member
    Messages: 13

    I ordered a kit today thanks ill let you know