1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

hand held control issues?

Discussion in 'Western Plows Discussion' started by Scenic Lawnscape, Mar 3, 2009.

  1. Scenic Lawnscape

    Scenic Lawnscape Senior Member
    Messages: 481

    I have a uni mount with a hand held controller, it is the old style that has the extra brown/orange wire for the ground, well I pulled that out by accident the other day doing something else, and then when I Fixed the wire the controller doesnt power up

    So here is what I have done, I have made sure the pump is working, I have tested the controller harness and I am getting power, I test the controller and I get it to light up if I put power direct to it like the book said

    I ran a new brown/rd wire because I wasnt getting the motor to power up doing the jumping between 1 and 4 sockets

    So I am out of ideas any help would be great
     
  2. Scenic Lawnscape

    Scenic Lawnscape Senior Member
    Messages: 481

    I also checked all fuses and replaced the starter solonoid
     
  3. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Lets start with the Brown/org wire which is actually black/orange. When you hooked it back up did you put it to ground on the battery and is it on the black orange terminal on the solenoid?
     
  4. Scenic Lawnscape

    Scenic Lawnscape Senior Member
    Messages: 481

    yes

    I followed the directions from the manual to trouble shoot it, and i am afraid i am just over looking something small

    Is there any other fuses that could be blown that would effect this?

    and thank you because this is driving me nuts, its the end of the season I want to be able to remove my plow so i can use my truck for other things and this happens
     
  5. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    did you check the 2 fuses in the controller?
     
  6. Scenic Lawnscape

    Scenic Lawnscape Senior Member
    Messages: 481

    i dont see any fuses in the controller(inside) there is one in line with the red wire and then one in line with that one

    there is a tag that say to use a sf-6 fuse on the controller but I dont see one
     
  7. Scenic Lawnscape

    Scenic Lawnscape Senior Member
    Messages: 481

    I was going to re do all the grounds in the morning and see if that helps
     
  8. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    If you have access to another controller, try that once and see what happens.