1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

H i d s

Discussion in 'Chevy Trucks' started by snow man 0311, Feb 24, 2012.

  1. snow man 0311

    snow man 0311 Member
    Messages: 66

    So I got one of the H id s kits from ebay and one of the ballast stopped working . So to make a long story short I got another pair and a hour if that the drivers one this time .wtf there made by xentec or somthing do i need the realay .I don't remember on my other silverado if I had it or not but htose are still going and this two stopped workin after a day or so...Btw 2003 silverado 2500hd
  2. gunsworth

    gunsworth Senior Member
    Messages: 498

    I went through 3 sets of ballasts on those xentecs last year, gave up and got the DDM Tuning ones and they have held up for the last 4 months
  3. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,328

    I have had DDM in both of my vehicles for two plus years now with no problems. An 04 Yukon and an 06 Sierra.
  4. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,719

    I've got DDM ones also. The ones in my fogs always work. My low beams always work too but sometimes they flip on and off when I try and turn them on. Once and a while I have to turn my lights off and back on to get both of them to stay on.
  5. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,328

    Relay should take care of that problem Mark. Mine are in the high beam. Once in a while one won't fire. Off and on and they work. Doesn't happen enough to bother me though.