1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Got the mvp mounted-have some questions.

Discussion in 'Western Plows Discussion' started by dupupp, Feb 8, 2009.

  1. dupupp

    dupupp Member
    Messages: 46

    I got my mvp mounted on my 05 chevy and everything works. my question is that when i go to scoop mode the right wing takes just a little longer than the left mode-is there anythig wrong there or is that normal. the plow is a 06 model and has been used maybe a couple of times. looks brand new. also my trucks votage gauge runs over 14 but when i use the plow it drops a quarter of the way down and the plow works fine and as soon as i let of the control it jumps right back to over 14-is this normal or maybe do i have something wrong-when i wired the plow i did not go straight to the battery but i got the postive from were is comes out of the batter and to the junction block under the alternater. and i grounded the plow solenoid to the firewall of the truck.
    thanks guys
    Rob
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Both conditions are totally normal and indicates no issues. One thing I would recommend is getting your positive cable directly on the battery.
     
  3. dupupp

    dupupp Member
    Messages: 46

    okay thanks-should i use the stock battery terminal or upgrade to something different?
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Nothing wrong with the stocker.
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    I was reading someone where on this site regarding battery. I was stated to use a battery that has a "side post" and a "top post". You would use the plow wires from the solenoid "+" to the top post positive and the "-" to the top post negatived. Get a battery that has good cranking amps. If I find the link I will post it
     
  6. as twinman said that is a pretty easy set up, if your truck is a sidepost do not cut the rubber around the factory connection, they are a great set up and if greased when installed will keep corrosion pretty much to nil.
     
  7. ps i have two mvps and both take longer on the right side, they all do it is even mentioned in the manual somewhere
     
  8. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

  9. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

  10. dupupp

    dupupp Member
    Messages: 46

    thanks for all the info guys-read everything and i am going to put the plow wires directly to the battery and then this summer add the dual battery setup for next year.
    thanks
    rob
     
  11. mrplow5885

    mrplow5885 Junior Member
    Messages: 18

    i have the plow comming off the post under the alt. i ran a 4gauge from the alt to that post and got rid of the stock alt. wire.
     
  12. mrplow5885

    mrplow5885 Junior Member
    Messages: 18

    i can send u pics of the tray i made for the second battery. the only place i was able to put it was against the firewall on the pass side.
     
  13. dupupp

    dupupp Member
    Messages: 46

    pics are always welcomed or post them in this thread for all to see.
    thanks
    Rob