1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Got my used Curtis on!!!!

Discussion in 'Equipment, Tools & Vehicle Pictures' started by 03SuperCrew330, Mar 16, 2007.

  1. 03SuperCrew330

    03SuperCrew330 Member
    Messages: 72

    Here it is all set to go today!!!


    Who needs a bumper :) I will get to that later!


    Only problem is when im driving the blade bleeds down, checked the fluid, no leak, is it a bad seal or valve leaking down?
  2. Petr51488

    Petr51488 Senior Member
    Messages: 262

    wow what happened to the bumper?
  3. bowtie_guy

    bowtie_guy Senior Member
    Messages: 551

    Looks good but a little late isn't it? :confused:
    Looks like someone already took their camaro out.
  4. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,719

    Whered your bumper go?? Or did you trade it for the plow? :D
  5. 03SuperCrew330

    03SuperCrew330 Member
    Messages: 72

    HAHAHAHAHA no its in the garage, I refuse to cut 38" out of my air dam for one storm!!!

    Yes the Camaro is out but so is the transmission...LOL!
  6. PremierLand

    PremierLand PlowSite.com Addict
    from detroit
    Messages: 1,572

    Why so late in the year to get it put on? Coulda put that money in the bank to earn interest and get a better plow next season and save on storage. lol. I had a curtis and I hated it, I hope you have better luck than I did.

    THEGOLDPRO PlowSite Veteran
    Messages: 3,136

    yeah all i gotta say is **** a ford, lol im kidding, lookd ok, lol
  8. BRIAN11

    BRIAN11 Junior Member
    from MA
    Messages: 15

    The float valve is the reason the blade falls. It's pretty easy to change. I beat my Curtis pretty good over it's lifetime and it hasn't failed me yet.