1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Glow Plugs '02 PSD

Discussion in 'Ford Trucks' started by wheeler4x4, Mar 1, 2009.

  1. wheeler4x4

    wheeler4x4 Member
    Messages: 38

    Can anybody tell me how many Glow Plugs are on a 2002 7.3 PSD? Also where are they located? By the exhaust manifolds or under the valve covers? Thanks for any and all help. wheeler :)
     
  2. u call i haul

    u call i haul Junior Member
    Messages: 2

    There are 8 one for each cylinder and yjet are under the valve covers
     
  3. wheeler4x4

    wheeler4x4 Member
    Messages: 38

    Uhg....I was hoping they were outside the valve overs. Thanks for the help. wheeler
     
  4. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    what problems are you having??
    don't work at all, only work once in a while, or throws a lot of white smoke on cold start?

    you may just need a glow plug relay.
     
  5. wheeler4x4

    wheeler4x4 Member
    Messages: 38

    Intermittent hard start after sitting overnite. Even when plugged in. Not a lot of smoke when it does finally start though.
     
  6. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    if it is hard starting even after sitting overnight plugged in, it sounds like you have a fuel problem, not a glow plug problem. unless the block heater is not working either.

    if the glow plugs and block heater are not working, it will blow all kinds of white smoke till it warms up. so your comment of no smoke once it starts up tells me it is a fuel problem and not a glow plug problem.